Tutorials/Puppet for Configuration Management

From LCA2010

< Tutorials(Difference between revisions)
Jump to: navigation, search
(Puppet for Configuration Management)
Current revision (15:13, 15 January 2010) (edit) (undo)
(Prerequisites)
 
Line 9: Line 9:
* an installation of a recent 1.8.5+ version of Ruby
* an installation of a recent 1.8.5+ version of Ruby
-
*NOTE: Puppet is a configuration management tool - some of the steps in the tutorial will change files, packages and configuration on your virtual machine. Do not bring a production VM (or if running locally - a laptop) that you are uncomfortable making changes on*
+
=== Puppet Packages ===
 +
* Debian: Puppet 0.25.1 from testing/unstable
 +
* Ubuntu: Karmic/Lucid have Puppet 0.24.8 which is OK. Otherwise, use the Debian unstable packages.
 +
* Fedora 11/12: Puppet 0.24.8 is in the base repository.
 +
 
 +
'''NOTE:''' Puppet is a configuration management tool - some of the steps in the tutorial will change files, packages and configuration on your virtual machine. Do not bring a production VM (or a laptop if you don't use a VM) upon which you are uncomfortable making changes.*

Current revision

Puppet for Configuration Management

Prerequisites

You will need to bring:

  • A laptop with wireless, running
  • a Linux/OSX/BSD virtual machine, with
  • an installation of a recent 1.8.5+ version of Ruby

Puppet Packages

  • Debian: Puppet 0.25.1 from testing/unstable
  • Ubuntu: Karmic/Lucid have Puppet 0.24.8 which is OK. Otherwise, use the Debian unstable packages.
  • Fedora 11/12: Puppet 0.24.8 is in the base repository.

NOTE: Puppet is a configuration management tool - some of the steps in the tutorial will change files, packages and configuration on your virtual machine. Do not bring a production VM (or a laptop if you don't use a VM) upon which you are uncomfortable making changes.*